CarnageBlender IP Connections...? (in Off-topic)


SNK3R April 26 2006 8:57 PM EDT

**You may want to load this thread in a new tab/window for easier reading.

Okay, so within the last few days, I've been having some extremely abnormal lag from only CarnageBlender.com. With the help of Brendan, I think we've narrowed down the problems, so I'll explain in a little bit more of detail below. It may be worth it to mention that my loading times for CB range to about 3.5 seconds to 10 seconds per fight and inbetween that for other pages when this problem exists. Normally, I'm able to complete a page load in roughly .5 seconds. (Yes, these are real numbers.)

If I ping www.carnageblender.com, I will receive the following results (this is most recent ping test):

Reply from 208.186.101.116: bytes=32 time=1229ms TTL=48
Reply from 208.186.101.116: bytes=32 time=1195ms TTL=49
Reply from 208.186.101.116: bytes=32 time=1147ms TTL=48
Reply from 208.186.101.116: bytes=32 time=1142ms TTL=49

From what I was able to understand from Brendan is that it's taking about even a whole second just to connection to the IP. (Please clarify if this is incorrect.)
If I ping www.google.com, I will receive the following results:

Reply from 66.102.7.104: bytes=32 time=23ms TTL=244
Reply from 66.102.7.104: bytes=32 time=22ms TTL=244
Reply from 66.102.7.104: bytes=32 time=22ms TTL=244
Reply from 66.102.7.104: bytes=32 time=23ms TTL=244


As you can see, there is a tremendous difference in 1200ms versus 23ms, which made Brendan and I believe that somehow in the connection of CB, there was something going on. I then downloaded 3D Traceroute to find out what connections are at what IP and how fast I'm pinging/connecting to them. The following image consists details of the most current test I did with www.CarnageBlender.com:



As you can see, I'm getting 5 connections with the very slow connection rate. This leads me to several questions I know nothing about and am inquiring about: Any additional information or help regarding this issue would be extremely appreciated. Also, another worthy mention is that this has only been happening within the past 1-2 days. The connection is pretty bad during the day. However, I found the connection to be quite snappy during the evening last night (getting 300ms compared to the 1200ms) and this morning. Also, this connection lag seems to only occur in connecting with www.CarnageBlender.com.

Admin{CB1}Slayer333 April 26 2006 9:12 PM EDT

well, other than the following, I have no clue : D

IIRC, CB does not allow you to connect from a proxy, so that is not an option

bartjan April 27 2006 1:34 AM EDT

If you use a proxy server, then the total latency you'll see is the latency between you and the proxy server plus the latency between the proxy server and CB. In normal cases this will be worse than a direct connection, but in your case it can help, if the proxy server is either near you or near CB and doesn't suffer from the same problem as you have.

CB *does* allow you to connect via a proxy server (if it didn't, then no one from AOL would be able to play ;) but what it does not allow is to connect via an open (i.e. rogue) proxy. So if you set up your own proxy (or have someone else do it) and configure it to require authentication (or another access control method), then it may work.

SNK3R April 27 2006 3:38 PM EDT

What I find interesting is that the 4 IPs after the green section all belong to Electric Lightwave Inc, by doing a WHOIS search. Is there anyway I can contact them and tell them to fix their problem, or will this not even be of any use? ;) (They give support/spam E-mails, but is this the right area?)

Also, if I use a Proxy Server, will I be open to more threats? Can you suggest some Proxy Servers for me? I'm not sure where to even begin to look.

And, again, why am I getting these horrible connections and nobody else on CB seems to do so? I just don't understand that.

Let me know if this is incorrect, but if logic is what it seems, then if I fix the red connections in order, I will be able to get my normal connection. Is that true, or could it be any of the red sections that is causing the slow connection?

Appreciate all the help so far.

AdminQBVerifex [Serenity In Chaos] April 27 2006 5:53 PM EDT

Bartjan, you said something I found interesting, you said CB doesn't allow rogue proxies to connect? Did this behavior change recently? Because I know a long time ago, probably 1 or 2 years ago, I tried connecting to CB from a proxy and I had no problem doing so.

If what bartjan said ISN'T true, then you could just type in public proxy list into google and find any number of alternate proxy servers to connect from. You probably want to find one in the United States, and not that it matters, but it won't matter if you get a transparent or anonymous one.

Timberwolf April 27 2006 5:54 PM EDT

I would send the information you presented above to them and see what happens. They may look into it, or they may blow you off.
It never hurts to try.

SNK3R April 27 2006 8:26 PM EDT

Looks like I've pretty much taken care of what I need to do in order for me to get a better connection onto CB thanks to Brendan. Although it's a temporary fix, it will work. I appreciate all the help, guys. ;)
This thread is closed to new posts. However, you are welcome to reference it from a new thread; link this with the html <a href="/bboard/q-and-a-fetch-msg.tcl?msg_id=001mwh">CarnageBlender IP Connections...?</a>