Something weird's going on...[Verifex's Greasemonkey Script Quick Fix] (in General)


Seran [Hidden Agenda] July 11 2006 10:15 PM EDT

Verifex's script forces another window to open when I click on a training preset. Someone help me with this.

Flamey July 11 2006 10:24 PM EDT

yea i just tried then, it opens in a new window. it worked fine a couple of hours ago....

SNK3R July 11 2006 10:47 PM EDT

The reason is because of Jon's newly changed name of the main frame.

If you want a quick fix instead of waiting for Verifex to fix it, open up the script in Notepad or Dreamweaver (or some other editor), go to line 104. The line should contain the following:

aer.target="main"

Change 'main' to 'cbmain'. Save it, then refresh your sidebar, and it'll be fixed. Enjoy.

SNK3R July 11 2006 10:54 PM EDT

Oh, and if you don't know how to find the script via folders, in Firefox, go to Tools > Manage User Scripts > click on 'Misc CB2 Enhancements' > click on 'Edit'. This should open the script in some kind of text editor, if you've set it to open in one. If not, search for Notepad's executable file or some other text editor and open it from that.

Alternatively, do the following: save the .JS file (go to Verifex's page with the script & save it) and save it on your computer. Find it, open it in Notepad, make the change I just said above this post, save it, right click the file, open with Firefox, install it, refresh the sidebar, and you're done.

SNK3R July 11 2006 10:59 PM EDT

Okay, so since most people still don't understand how to fix it, here's the easiest fix of all:

Go to Tools > Manage User Scripts > Uninstall Misc 2 Enhancements.
Then, right click this and install this script. Refresh the sidebar and you're good to go!

AdminQBVerifex [Serenity In Chaos] July 12 2006 1:45 AM EDT

Or, you can just refresh your sidebar now.. :) BTW I updated the "Update" part of the script so that it works a little better now and doesn't cause so much chaos..

QBPixel Sage July 12 2006 1:59 AM EDT

Hmmm, I wonder what this change is preparing us for...

;)

AdminQBVerifex [Serenity In Chaos] July 12 2006 3:09 AM EDT

If you installed the script in the past few hours, please uninstall, and install the new one. I messed it up.. doh! I'll probably update it again soon.

BlueWolf July 12 2006 6:56 AM EDT

so what new stuff is in it? or is it just updated for forging times?

AdminG Beee July 12 2006 8:29 AM EDT

OK, I'm obviously doing something wrong because the link SNK posted isn't working for me.

I've uninstalled and (to the best of my knowledge) followed the instructions and it's not working. I'm getting the message to say the script is installed but it doesn't appear to be so and it's certainly not visible after a refresh of the sidebar or launch of a new browser window.

I've had to re-install the old script from a previous forum post to get back to basics. My train page is opening in a new window using this old version, but then again that's to be expected I guess until I get myself sorted out.

Flamey July 12 2006 9:02 AM EDT

well while 'fex was doing this, he told me what to do. as he stuffed up things, i think you should just do it this way.

uninstall it.
goto help and external CB resources and open in new tab/window and install it from there and refresh your sidebar! and there it is.

SNK3R July 12 2006 9:11 AM EDT

Bren took down my file in the link, G, after he 'fixed' his script.

AdminQBVerifex [Serenity In Chaos] July 12 2006 3:09 PM EDT

Yeah, the update function works better now, sorry I was trying to contact you SNK, but the former script you posted was right, but I needed to fix the "update" script part, since it has been horrible for a long time, now it won't cause all the CB frames to break. And I just took this opportunity to update that part :)

AdminG Beee July 12 2006 5:38 PM EDT

Is it just me?? Am I the only one who still can't actually fix this?

Training is still opening in another tab for me.

I think you're going to have to talk slower (or louder) for me 'fex because I'm not getting this at all... :)

AdminG Beee July 12 2006 6:10 PM EDT

I'm sorted :)

Thanks to 'fex for the script and to Zhakrin for speaking to me "slowly" in my CM and explaining what he did to fix the same issue :)

Smart not am I sometimes, heavy things lift I can :)

Revs July 12 2006 9:14 PM EDT

So early on in this thread I uninstalled, then re-installed from the help section. And now . . . it only partially works. I have the menu in the sidebar, but that's it. Now train save option, no auto move on the fightlist, etc. Ideas?

AdminQBVerifex [Serenity In Chaos] July 12 2006 9:16 PM EDT

Uninstall the script rev. and reinstall it from the help section.

SNK3R July 12 2006 9:16 PM EDT

Make sure you have version 2.3 (the newest edition) installed. In addition, make sure you only have one version installed at a time -- uninstall any previous scripts.

Revs July 12 2006 9:32 PM EDT

Ok, thank you. Did all that and it still wasn't working quite right until I remembered the obvious, that I play by IP adress to avoid a nasty little filter at the local net cafe I frequent. So I had to add the http://208.186.101.116/* , which in retrospect was my initial problem on the re-install.

SNK3R July 12 2006 9:32 PM EDT

Didn't I tell you to add that to the included list, Bren?!

Now you'll listen to me... ;)
This thread is closed to new posts. However, you are welcome to reference it from a new thread; link this with the html <a href="/bboard/q-and-a-fetch-msg.tcl?msg_id=001qsk">Something weird's going on...[Verifex's Greasemonkey Script Quick Fix]</a>