More computer help needed. (in Off-topic)


AdminQBGentlemanLoser [{END}] July 18 2006 6:17 PM EDT

I'm ripping my hair out with my other halfs computer. >_<

She has intermitent internet connection, and I can't figure out the problem.

I'm typing this from her computer, as CB is one of the couple of site that will actually load.

She has FF in addition to IE and NIS 2006. Everything was working fine until a little while ago.

Now, FF throws up "server not found" for most pages and IE Can't find page...

I have changed settings in NIS and even disabled it to see if it makes any difference, but it doesn't seem to.

Even when I tihnk I've fixed it, it'll work for 5/10 minutes, then break again. :(

I really don't know what to do. :(

AdminJonathan July 18 2006 6:19 PM EDT

sounds like flaky network hardware...

AdminQBVerifex [Serenity In Chaos] July 18 2006 6:33 PM EDT

You would probably have to uninstall NIS for anything to work. Alot of firewall programs these days have settings which prevent the network from working when they are not loaded. Also the firewall settings could be messed up.

There is a chance that you have some setting to "allow" web filtering on your connection and it is either messed up, or NIS itself is corrupt which I would definiately not rule-out.

I would suggest a number of other free products to take care of security, such as...

http://free.grisoft.com/ - AVG Antivirus - Free

http://www.safer-networking.org/ - Spyboy Search & Destroy (make sure to install teatimer) - Free

http://www.winpatrol.com/ - Winpatrol Spyware/Hijack Prevention - Free

http://www.lavasoftusa.com/software/adaware/ - Ad-Aware SE - Free

http://www.microsoft.com/athome/security/spyware/software/default.mspx - Windows Defender - Free (with Genuine advantage verification)

http://www.sunbelt-software.com/Kerio.cfm - Kerio Personal Firewall, works after 30 day trial too.

AdminQBGentlemanLoser [{END}] July 18 2006 6:39 PM EDT

:) Thanks.

Looks like I should probably try to un install NIS. :/

It came (well 1/2 price) with Claire's new PC and has been working fine for months.

Claire already has AVG, SS&D and Ad-aware. I wouldn't be without these. ;)

QBSefton [Black Cheetah Bazaar] July 18 2006 6:40 PM EDT

GL a couple of things to try. First as soon as you get a server not found error, open up a command window (start>run>command) and type ping (the url that errored)

Look for a) a translation like this:
Pinging www.yahoo.akadns.net [209.73.186.238] with 32 bytes of data:

This means DNS is working, even if the pings wont go through.

Then look for b)
Reply from 209.73.186.238: bytes=32 time=41ms TTL=50

Something like that. If BOTH occurs (meaning you get DNS translation and ping replies) but still the browsers errors out, you might have gotten some spyware into your TCPIP stack that is redirecting the majority of your URLs to a now non-existant spyware server, this could even be a modification of your HOST file.

If either function fails in the command window, then you can begin to look at a lower level. If you get DNS but not pings, then you are really in a weird spot, DNS means you have a connection to the provider and they are able to provide your translation, but the traffic is not being passed. This is likely a provider problem.

If both fail (if DNS fails ping will fail) then you need to run a couple more tests. I will assume you have a gateway. It is either a modem or a router, but it has an internal IP address that should only be accessable from your side of the connection. You need to find out what its address is (likely like 10.0.0.1 or 192.168.0.1), and try pinging it. If you can ping it, then likely it is not a NIC problem (the place where you plug the ethernet connection into computer) but something in the gateway. If you cannot ping your gateway, but 10 minutes later you can, then it is likely a NIC problem (then rejoice for a new NIC is like $10 USD)

You can very easily borrow a working NIC from someone and test that directly if you do not want to go through all my ping testing.

There are a bunch of spyware type applications that can cause this symptom. Download, install, update, and run Spybot Search and Destroy. It should find and kill most if not all of them for free. If it has any trouble we may have to get to HiJack this, but you will want to send me that log before messing with the stuff in HiJack this because you could easily mess up the computer more if you use it and do not know what you are doing.

If you want some advanced ideas on troubleshooting, I can offer my email address and we could get into a more detailed discussion (also I can all anywhere in the US for free if need be, but not the UK)

AdminQBnovice [Cult of the Valaraukar] July 18 2006 6:50 PM EDT

You've gotten the standard list of suggestions, but I had to second (and third, and fouth) the idea of nuking NIS. It's like a rotting carcass that stinks up your computer, and occasionally brings everything to a grinding halt. I've seen people who've been running it for months suddenly be completely unable to get online. I will say that the intermitent nature of this does sound more like a hosts file issue, or a lovely parasite leeching off your TCP/IP stack...

AdminQBVerifex [Serenity In Chaos] July 18 2006 7:12 PM EDT

One of the great things is that I think one of those programs I mentioned actually monitors the Hosts file to prevent the kind of hijacking Sefton is talking about. That is a good idea though Sefton. I would say anything more complex then what we have suggested already GL is going to be too complex.

Like for instance I was playing with Ethereal a couple days ago and I found weird stuff going out a port on my PC. I was running BitComet, and it just so happened one of my peers on the network happened to have their incoming port set to 110, and therefore I thought I had been hacked with a virus or something since I was sending out to this port, but no, it was just someone being tricky, probably trying to get around a firewall or port filtering.

AdminQBGentlemanLoser [{END}] July 18 2006 7:14 PM EDT

OK, little more info.

I un installed NIS. Didn't help with the problem, but the computer is running visably faster. :)

I can still connect to CB, but can't to something like www.yahoo.co.uk.

I tried pinging yahoo, but got "Ping request could not find host www.yahoo.co.uk. Please check the name and try again."

I can ping my computer on 192.168.0.1 (that's my LAN IP isn't it?) and the IP given by my ADSL Modem.

Claire is very prompt with virus/spyware scan, but I'll leave them running tonight and check them in the morning.

Thanks for all the help! :D

AdminQBnovice [Cult of the Valaraukar] July 18 2006 7:18 PM EDT

Do an ipconfig in dos (or check the support panel under status for your LAN connection [Network Connections CP, right click on lan and go to status then support]) and note your DNS or name servers. It sounds as though maybe your ISP is experiencing some issue with DNS.

AdminQBGentlemanLoser [{END}] July 18 2006 7:20 PM EDT

But my computer works fine. Claire is connected to the internet through mine, I can get to sites she can't. :/

AdminQBnovice [Cult of the Valaraukar] July 18 2006 7:23 PM EDT

Use spybot's tools to check out the hosts file, and don't hesitate to add the black list they give you while you're there.

QBSefton [Black Cheetah Bazaar] July 18 2006 7:24 PM EDT

wait a sec, you are using Internet Connection sharing, or some kind of peer to peer connection for your two computers?

That makes a big difference and creates an entirely new set of problems.

Does it go modem/router <-------> your computer <-----> her computer as in you have like through USB or a second NIC directly connecting Claire's to your computer, then your computer is connecting to the gateway?

AdminQBGentlemanLoser [{END}] July 18 2006 7:32 PM EDT

Doh! I left all that out..

Yeah, the way the last two ISPs were set up over here, only my PC could be connected (This started off with broadband from NTL It ran from thier TV set top box and had to connect to a NIC in a single computer...). I toyed orginally with a RJ45 crosover cable from a second NIC on my PC to one of Caires, but instead opted for a 4 port Switch (For the odd occasions my mates bring thier PCs/Laptops over...).

Claire connects to the internet through my PC using the fabulous MS ICS (And the reason I had to upgrade to the pro version of ZA as the free version doesn't support ICS

It's been working fine for ages. :(.

QBSefton [Black Cheetah Bazaar] July 18 2006 7:39 PM EDT

Here has been my experience with Microsoft. They usually break their own stuff. FIRST thing I would suspect is an automatically downloaded and applied update. Probably happened right before the problem occured. You might see if the update is uninstallable, if not you might have to resort to System Restore (SHUDDDERRRRRR), no dont go there.

Instead, try searching the net for a simlilar problem, usually there will be a KB post or a google forum post on the subject with the "soon" to be released patch or similiar type solution. Again, the computer community will likely solve it long before MS does. I have often found it's usually one tiny little key in your registry needs to go from 0 to 1 or vice versa or be deleted.

AdminQBGentlemanLoser [{END}] July 18 2006 8:22 PM EDT

Right,I think I've found the problem, I just need to find the solution now...

I think the problem stems from the new ISP Claire moved us to from NTL.

As far as I can gather the ASDL modem we have uses PPPoE, which doesn't work well with ICS.

Changing MTU values (from 1500 to something like 1454) has been offered as a solution, as is installing RASPPPoE?

It's too late now, going to bed. At least I have somewhere to look tomorrow! ;) Thanks again everyone! :D

AdminQBVerifex [Serenity In Chaos] July 18 2006 11:16 PM EDT

I don't know ICS that well unfortunately. Do you not have a extra router laying around? Seems kinda weird to go to all that trouble when you could simply have a router do it all for you. Hook the router to the switch and not worry about having your PC on all the time.

AdminQBnovice [Cult of the Valaraukar] July 18 2006 11:20 PM EDT

Download the vmware player and one of the images with a complete firewall with a gui config system. Some of us around here can help with questions, and it's free! You'll also be running the firewall in a separate operating system, which will help with security a lot.

bartjan July 19 2006 2:01 AM EDT

Replacing your ADSL modem with an ADSL router will, once setup, solve most of your network problems. Both computers then are connected to the router's builtin switch. No need for ICS.
As an added bonus, your computer doesn't needs to be running for Claire to use her computer on the Internet.

bartjan July 19 2006 2:35 AM EDT

Are you sure that you are using PPPoE and not PPPoA?
What's the ISP?

AdminQBGentlemanLoser [{END}] July 19 2006 3:11 AM EDT

ISP is Tiscali.

bartjan July 19 2006 3:44 AM EDT

This page claims it's PPPoA. That page also lists the settings that need to be set, if you get an ADSL router.

AdminQBGentlemanLoser [{END}] July 19 2006 4:22 AM EDT

Ah thanks! :D Right, back to hunting out a solution. :) If I can't it's time to get Claire to losen the purse strings, and get a Router. But if we do, I'd be partial to getting a wireless one. :)

bartjan July 19 2006 4:47 AM EDT

Isn't "no more wires through the house" a convincing argument?

AdminQBGentlemanLoser [{END}] July 19 2006 4:49 AM EDT

:D I hope so, but she's already made me get long enough cables to run everything round the walls, under our carpet... ;)

QBJohnnywas July 19 2006 4:52 AM EDT

It's not just me that gets the moans about the wires then? Although admittedly my situation is pretty bad, having a recording studio in the back living room....cables everywhere....

AdminQBGentlemanLoser [{END}] July 19 2006 5:54 AM EDT

LOL!

More info from trying to follow MS KB advice...

Taking www.yahoo.co.uk as the site to test with. Claire can ping the IP of the site, and can ping the name.

But when you try to open the website by IP instead of name (either typing the IP into the address bar or using start/run/IP) it doesn't open.

I'm beginning to think this might be a problem on Claire's PC, but it might still be ICS and PPPoA/E from Tiscali...

*sigh*

>_<

bartjan July 19 2006 5:57 AM EDT

You can't just expect accessing a website by IP to work. In many cases more than 1 website is on 1 IP. You'll need to access the website by the hostname, or else the webserver can't tell what website you want and either generates an error page, or guesses for you.

AdminQBGentlemanLoser [{END}] July 19 2006 11:30 AM EDT

I think I might have fixed it! ;)

I've assigned Claire a static IP addres and used the two DNS servers given in Tiscali's router set up section.

It seems to have worked so far, I'm getting Claire to use the itnernet for a while to make sure! :D
This thread is closed to new posts. However, you are welcome to reference it from a new thread; link this with the html <a href="/bboard/q-and-a-fetch-msg.tcl?msg_id=001rGz">More computer help needed.</a>