Need help! (in Off-topic)


[me]Davis August 4 2006 1:03 PM EDT

My Logitech Optical Mouse just stopped responding and i have like tried everything... I tried unplugging the usb cord that goes into the usb to mouse thingie, unplugged the usb to mouse thingie, plugged the usb cord directly into the usb slot, turned off the mouse and turned it back on, reset it, tried reconnecting it, none of it works... i was able to get on and ask for help using my keyboard.. i wanna fix my mouse as soon as possible cause this is getting difficult using my keyboard.... please someone help

Zoglog[T] [big bucks] August 4 2006 1:09 PM EDT

We would be much happier to help if we understood exactly what you mean by "thingie", we need to know exactly what you have tried (using technical or at least loosely technical wording) so as to recommend a proper solution.

[me]Davis August 4 2006 1:13 PM EDT

i don't know what it is.... my mouse has a usb cord instead of a standard mouse cord and to make the usb fit into the mouse slot there is a converter thing that allows it to fit into the mouse slot on the tower

Brakke Bres [Ow man] August 4 2006 1:14 PM EDT

Is it an cordless optical mouse?

Does it have an receiver and not a combo receiver/recharger?

Do you have another mouse you could plug in?
Do you have the latest mouseware?
Did you check the batteries?
Did you try restarting the operating system?

My logitech mouse gave me the same problems.
Try reconnecting it when windows or your OS is starting up.

Maelstrom August 4 2006 1:39 PM EDT

I often have trouble with optical mice. Sometimes restarting the computer will solve it. I think some media player on my computer also causes my mouse to freeze, strangely...

bartjan August 4 2006 2:33 PM EDT

  • Is the mouse listed in the output of "lsusb"?
  • Does the output of "dmesg" show anything interesting about the mouse or USB?
  • How does the mouse's InputDevice section from /etc/X11/xorg.conf look like?

Of course, if your computer is not running Linux, the above does not apply to you. In that case, it would really help if you specified whatever Operating System you are using.

Another tip, if some hardware doesn't work, and you're uncertain if it's the hardware or the operating system that's causing the problems: download Koppix and burn it to a CDrom. If it works in Knoppix, the hardware is not broken.

AdminQBVerifex [Serenity In Chaos] August 4 2006 4:15 PM EDT

Man, Knoppix is so cool. Now I need a Mobo/Bios that lets me boot from USB, I've seen a couple things that let you boot from usb that just looks way too cool.

AdminQBGentlemanLoser [{END}] August 4 2006 4:19 PM EDT

When plugging in a mouse to the 'mouse' slot (or using a USB converter) you need to re start you PC before it will recognise the mouse. Plugging it into a USB slot shouldn't suffer that handicap.

Does the light in place of your mouse wheel still illuminate? When you pass your hand in front of it, does it light up?

AdminG Beee August 4 2006 5:01 PM EDT

Sounds to me as if one of the "thingies" you're talking about is a USB to PS/2 adaptor?

You have a USB optical mouse with an older PC that doesn't have many USB slots?

Anyway, you've got us guessing as you've not really given much info. If you are using the mouse on a PC via the PS/2 slot try uninstalling then re-installing any software that came with it.
Also, are you sure the mouse hasn't just broken all of a sudden - does it still work on a different machine for example?

PS. Should've bought a microsoft mouse anyway :)

AdminQBGentlemanLoser [{END}] August 4 2006 5:08 PM EDT

I've got a packard Bell optical mouse (a logitech clone really) that's lasted me years!

My sweaty palms have eroded the silver colour from some areas of the mouse (palm and points where my fingers rest on the buttons!), but that's about it! ;)

I think it was on offer from PC world! ;) I'm sure I'm using a USB to PS/2 adapter with it ;)

AdminQBGentlemanLoser [{END}] August 4 2006 6:23 PM EDT

"turned off the mouse and turned it back on"

Missed that. :/ Is it a wireless mouse? Does it run off batteries? Do they just need replacing?

deifeln August 4 2006 10:03 PM EDT

"My sweaty palms have eroded the silver colour from some areas of the mouse"



Ewwwwwwww!

[me]Davis August 4 2006 11:16 PM EDT

hmm i've tried everything... i think the problem is the connection between the mouse and the reciever.... and i don't know how to fix that...
This thread is closed to new posts. However, you are welcome to reference it from a new thread; link this with the html <a href="/bboard/q-and-a-fetch-msg.tcl?msg_id=001sEG">Need help!</a>