Need help finding a bug (in General)


AdminNightStrike December 2 2010 3:09 PM EST

There are a bunch of error messages in the log file from people trying to fight someone, but passing in the name as the id number to fight.tcl. This is most likely caused by a bad link somewhere on the site of the form:

...fight.tcl?opponent_id=MyName

instead of:

...fight.tcl?opponent_name=MyName
or
...fight.tcl?opponent_id=123

I can't find where the bad link is, though. So.....

Can you guys try fighting people through all the non-standard methods and telling me which one drops a server error? For instance, there's an F next to people in the recent battles list, and there's a Fight link if you go to edit your favorites list.

Thanks!

Eliteofdelete [Battle Royale] December 2 2010 3:14 PM EST

When I would inspect someone and then use the fight button to fight them, it kept saying I was fighting to fast. I tried restarting the browser/refreshing/ect, but it kept telling me I was fighting too fast. So I stopped using that method for a bit. It is working fine now tho so I am not sure if that is what your looking for.

Angel of Death [Hell Blenders] December 2 2010 3:21 PM EST

i found the bug, its between spits teeth

horseguy001 December 2 2010 3:23 PM EST

I tried fighting every way I can and I didn't have any problems.

When I clicked the (F) in recent battles it seemed like it took longer to process the fight, but it might just be my lame work computer :)

Pwned December 2 2010 5:10 PM EST

Could it be retired tourney chars? I'll bet the errors are from the tourney.

AdminNightStrike December 2 2010 5:18 PM EST

It could be. One of the characters that someone tried to fight was Mini Weat.

Eliteofdelete [Battle Royale] December 2 2010 5:19 PM EST

That would probably be me with the tourney character.

AdminNightStrike December 2 2010 11:54 PM EST

Can you replicate what you did?

Eliteofdelete [Battle Royale] December 3 2010 12:40 AM EST

Would be difficult since the tourney is over. Not sure if I could do it again even if it was working tho. I didn't have that problem after using recent battles to fight people for awhile.
This thread is closed to new posts. However, you are welcome to reference it from a new thread; link this with the html <a href="/bboard/q-and-a-fetch-msg.tcl?msg_id=0038Cn">Need help finding a bug</a>