battlecry not working.....? (in General)


Jason Bourne April 22 2005 1:30 AM EDT

ok spawn's battlecry is not working, but nightmare's is working fine...(yes spawn has one...)

heres a battle...

Nightmare cast Antimagic Field on Vague (0.19)
Something cast Dispel Magic on all enemy Minions (12,256)
Ranged Combat
Spawn skewered Something [3120]
Spawn skewered Something [3784]
Vague takes damage from his own Fireball (816)!
Vague's Fireball hit Spawn [2501], Nightmare [1751]
R.I.P. Something
 
Spawn hit Something's familiar [1959]
Nightmare's Magic missile hit Something's familiar [6534]
Nightmare cries "Dead already?!"
Vague takes damage from his own Fireball (933)!
Vague's Fireball hit Spawn [3004], Nightmare [3030]
R.I.P. Something's familiar
 
Spawn shot Vague [4400]
Spawn skewered Vague [4158]
Vague takes damage from his own Fireball (1050)!
Vague's Fireball hit Spawn [2603], Nightmare [3204]
R.I.P. Vague
 

spawn should be shouting "souls, come unto me!" when he kills the two guys, but it is not working. maybe i didnt do something right, or it doesnt work for tanks in ranged....is there a way i could turn it on?

smallpau1 - Go Blues [Lower My Fees] April 22 2005 2:02 AM EDT

In this case maybe he when he hit himself with his own fireball.

But yes Battle Cries are still a bit screwy, mine for sure is not working, cuz i hit one guy and then nothing hit him from his own team and he missed even attacking me, then RIP hes dead but no ...Battle cry: "That's it. Time out for you!!!"....lol.

Jason Bourne April 22 2005 2:17 AM EDT

yea i know, i like my battlecry, i just wich i could get it to work..

Undertow April 22 2005 2:19 AM EDT

I'm almost positive that it's because the "final damage" comes from the AMF backlash. Therefore, spawn didn't kill anyone, the casters killed themselves.

Fishead April 22 2005 3:44 AM EDT

It's not from final AMF, GA or CoBF damage. My back tank will hack a mage with his BTh and still not have a battle cry. No other damage done to the final minion other than a melee weapon.

Jason Bourne April 22 2005 4:25 AM EDT

it seems to only be happening to tanks...something to look into perhaps. ne1 else with the same problem?

Wasp [Demon Forging] April 22 2005 4:29 AM EDT

Mine never works either, im suprised to see it every once in a while
This thread is closed to new posts. However, you are welcome to reference it from a new thread; link this with the html <a href="/bboard/q-and-a-fetch-msg.tcl?msg_id=001Ipj">battlecry not working.....?</a>