Windows XP problem. (in Off-topic)


AdminG Beee April 24 2006 4:11 PM EDT

For no apparent reason the Welcome Logon Screen on my desktop is no longer letting me select a user account to start. The only option I can select is the log off option. My PC has been rendered useless as a result.

I've rebooted. I've googled. I've forced the pc to boot in safe mode and I still get the same screen and no option to select users.
I was hoping to be able to hit a Function key whilst booting up that would allow me to do something to fix it, such as bypass the login screen and go straight into the O/S directly.
Nothing has been downloaded onto my pc recently so there's no reason to suspect I've imported a virus of any kind. I also have up to date firewall and virus software installed.

Suggestions anyone ?

Screenshot of my new Welcome screen with no option to select user:

QBBast [Hidden Agenda] April 24 2006 4:12 PM EDT

Thank you, Mrs. Beee! :)

th00p April 24 2006 4:17 PM EDT

G_Beee: I've found the problem and a good solution.

Problem: You're using Windows.

Solution: Get Linux.

I'm special, my mommy tells me that every day.

;-)

AdminQBnovice [Cult of the Valaraukar] April 24 2006 4:24 PM EDT

fire whomever photoshopped out the user names in that screen shot?

InebriatedArsonist April 24 2006 4:30 PM EDT

Well, Beee, this is certainly a problem I have never previously encountered. Beyond playing around with tab and the arrow keys, I'm afraid you're on the verge of wiping the drive and starting over.

Maelstrom April 24 2006 5:11 PM EDT

I'm sure I've heard of that problem before. I think it's some security mechanism, where it hides the user names... or something. What have you covered up with photoshop? That would give us a better idea of what's wrong.

I'd suggest searching Annoyances.org for your problem, and if you don't find it, post in the forum there.

Timberwolf April 24 2006 5:14 PM EDT

I'm with novice on this one.
Find the person that keeps covering your logins with Photoshop, and you've solved your problem.

QBSefton [Black Cheetah Bazaar] April 24 2006 5:16 PM EDT

I think you can fix your problem from information in this link

http://www.kellys-korner-xp.com/win_xp_passwords.htm

:)

AdminG Beee April 24 2006 5:27 PM EDT

The photoshop was just me blanking out some user names from an image I grabbed to show the problem. It's not relevant to my issues...

/me goes off to the web sites posted to see if I can find something.

Maelstrom April 24 2006 5:30 PM EDT

So you mean it shows the names, but nothing happens when you click on them? That's weird... but I think Sefton's page might have a way to solve your problem.

InebriatedArsonist April 24 2006 5:37 PM EDT

I think Beee meant that he blanked out the names from an image he found elsewhere on the web, Mael.

AdminG Beee April 24 2006 5:44 PM EDT

Indeed that what I meant IA. The image you see is what I'm greeted with. There's nothing for me to "click" except the Turn of computer link. Just imagine I did an excellent job with the photoshop ok ?

As for the link Seft put up - I can't get to the command prompt to do this. That's part of my problem.

QBSefton [Black Cheetah Bazaar] April 24 2006 5:49 PM EDT

I am pretty sure you can F7 to interrupt and when you get that safe mode screen one option is to dump to command line there. Now, you may not have all the log in permissions at that point, so it may not help, but I would try it.

Again, after the post (when the screen shot shows your IDE device arrays) continously hit F7 and you should get a DOS screen with the safe mode option and one option should be command prompt with networking. From there, try some of the suggestions in the post.

AdminQBVerifex [Serenity In Chaos] April 24 2006 5:55 PM EDT

I would suggest what sefton said. I don't know exactly how you managed to erase all the primary user accounts but, whoever did that was not very smart.

Anyways, try safe mode and see if you can add another administrator account from there. Although I wouldn't be surprised if you cant. :/

molans[Grumpy] April 24 2006 5:59 PM EDT

Go to
http://www.langa.com/newsletters/2003/2003-04-03.htm
and read article:
3) More Tips/Tweaks For "Fast User-Switching".
It might help.

AdminG Beee April 24 2006 5:59 PM EDT

F7 on it's own does nothing. F8 takes me to the following options screen.

Safe Mode
Safe Mode with newtorking
Safe Mode with command prompt
Enable boot logging
Enable vga mode
Last known good config (your most recent settings that worked)
Directory services restore mode (windows domain controllers only)
debugging mode
disable automatic restart on sys failure
start windows normally
reboot
return to os choices menu


I've been through all of these options one by one and they merely take me to the screen image I've posted - no matter what's been selected. I'm about to see if this thing will bounce from my upstairs window to the driveway below..!

AdminQBnovice [Cult of the Valaraukar] April 24 2006 6:01 PM EDT

Safe mode with command prompt gave you the same screen?

InebriatedArsonist April 24 2006 6:01 PM EDT

Do you have a lot of information on the drive that you haven't bothered to back up?

Sir Leon [Soup Ream] April 24 2006 6:03 PM EDT

Alright im no computer expert here especially compared to half these cbers. But heres a lil i know.

Sounds as though something has apparently happend in your system32 file. This problem is prolly associated with logonui. (It something like that as i dont fully remember the name). I havent a clue as to how this could become corrupt and your computer is still boot up. I do know that it has to do with what displays as your logon screen. I couldnt tell you how to fix this. Other than reinstalling windows xp. Do not reformat. This is to try to recover any files.

Just a small simple suggestion and information. Maybe it will help someone else think of the real problem and solution. Now ill try to google it.

AdminQBnovice [Cult of the Valaraukar] April 24 2006 6:03 PM EDT

"Also, when you're at the Welcome Screen, you can hit "CTRL+ALT+DELETE" twice in succession (I usually hold "CTRL" and "ALT" & just hit the "DEL" key twice) to bring up the classic login. Hit the "ESC" key to return to the welcome screen" - stolen from a link above.

AdminG Beee April 24 2006 6:16 PM EDT

lol, keep the suggestions coming but so far we're not getting anywhere.

I've worked through all the options and they take me to the same screen - even the safe mode ones. Safe mode just changes the resolution as you would expect.

I'm not the most technically gifted but I'm past the windows for dummies stage and have tried a lot of stuff. Currently working through the recovery console after inserting my XP original CD.

Vestax ;) The accounts weren't deleted by anyone but yes, they do appear to have been deleted. Wifey was last to use the pc in the morning before going to work. She used it for CB, switched it off and back on again 8 hrs later - the problem 1st happened then.

Keep the suggestions coming - i've googled this already for a while before posting and nothing seems to be obvious, at least not to me.

Tezmac April 24 2006 6:24 PM EDT

Hmmm, I checked the MS Knowledge Base and the Symantec VIL and couldn't find anything. I haven't run into this one yet (and my users at the office are awesome at hosing their machines). I'll keep my eyes open, but I'm sure your patience will run out shortly and you'll be rebuilding XP.

SNK3R April 24 2006 6:45 PM EDT

I've tried helping him, but he has a *real* problem getting to any sort of command prompt. You can at least try some things through it, but if he can't get to the command prompt or Recovery Console via Windows XP Installation Disk, there's not many options left.

Maelstrom April 24 2006 7:00 PM EDT

You could remove the hard drive from your computer, change the pin so it's a slave drive, and hook it up to another computer. The other computer should boot up normally (ignoring the OS on your drive), then you could either try to repair whatever files are corrupted on your drive, or just back up your data and reformat.

QBSefton [Black Cheetah Bazaar] April 24 2006 7:06 PM EDT

Last but not least there is always boot to DOS from floppy. Might need to beef up the programs on the floppy with a few nice DOS programs. Once there you can if nothing else, manipulate the raw data on the harddrive. You will not be able to execute any programs on the harddrive.

You can however, move, delete, rename, etc, and perhaps you could alter the password file in such a way as detailed in one of the web sites to force it to try and recover the password file or even make you create a new one.

Lastly there is the Linux option, dual boot, if you can get Linux to mount the XP drive, well I am sure there are some hacks that way ;)

faedarklight April 24 2006 7:20 PM EDT

Most likely you will have to reinstall windows due to a corrupt file. They like to go bad for no reason they just die. Unless you have been moneying in your registry.....at which point i tell you now DON'T!!!

You can look for this nifty thing called Boot and Nuke. If you can't find it give me a shout I can email it to you zipped. This will reset all admin and all user passwords as well as accounts. They are most likely locked out from some virus or whatnot.

InebriatedArsonist April 24 2006 7:22 PM EDT

You could also try using one of the programs on a rescue CD, such as Trinity Rescue. At the very least, you might be able to save most of your important data if you have no options left before reformatting the drive.

faedarklight April 24 2006 7:25 PM EDT

Something may have simply locked the accounts...The more i think about it I ran into this issue and it happened just because...but if you use the Bot and Nuke (not as nasty as it sounds) and they stil do not show then you will have to reinstall.

InebriatedArsonist April 24 2006 7:25 PM EDT

Doh, the links got screwed up. That would be Trinity Rescue and System Rescue.

faedarklight April 24 2006 7:28 PM EDT

Rawr If you have the actual windows disk you may be able to do a repair ( Returns to Last Known Goog Configuration) if you don't want to do anything myself or inebriated mentioned

[Redneck RV] Truc April 24 2006 7:38 PM EDT

Can you see a cursor?

( If not, I'm thinking you should peel off the big sticker that is affixed to your screen that just *looks* like a Windows log-on screen :P )

AdminG Beee May 13 2006 11:02 AM EDT

Here's what I've done so far...

All of the user accounts appear to have been deleted. I have no idea how this has happened but at the moment I'm putting it down to a quirk of the lovable o/s that is Windows XP. Wifey used the PC as normal in the morning, switched it off and went to work, came home and switched it on, no users to choose from... It's been a redundant piece of equipment ever since.

Pressing CTRL+ALT+DEL (twice) at the welcome window takes me to a "Log on to Windows" screen. None of the accounts are available via a drop down and user name / password are asked for. I've typed all the user names I have ever used and none work - at no time was there ever a password set so I have nothing to enter in there. So, I try logging in by using "administrator" as the user name and use all kinds of combination of password I would ever be likely to use... still no luck. I've never set an admin password on this machine so there's no need for me to be putting in a password. Let me say that again to avoid any doubt - I've_never_used an admin password so this is not a case of me forgetting it, losing it etc etc, there's never been password protection on this pc for any of the user accounts.

So, now that I've established that all my user accounts are "missing" and recognised that I've went through a lot of the common sense approaches to fixing the problems, both from my own experience and that of the suggestions above I looked into it further.
Given that I can now navigate to a screen that asks me for user name and password (remember none have_ever_been used) I decided to "pretend" I had actually had a password and that I'd forgotten it. Using this method I googled "I forgot my Administrator Password" and tried to get in this way.

So, Using my Windows XP CD I booted my PC.
I selected R for repair and went through the process until I was prompted for a reboot.
After reboot and when the windows XP was doing it's stuff "Installing Devices" I used the SHIFT+F10 key to exploit a so called security hole and open up a command console.
From here I was able to type NUSRMGR.CPL and bring up the User Accounts in a control panel. SIGH... It was EMPTY! So it's official, all my user accounts have been "vanished". My intention had been to select the admin account and change the password (which I've never set anyway).

So, what next...

OK, I decided to try and fool my PC into booting up without actually looking for a password seeing as it seems to think I need one.

Going back to the command console I went back to the c: and typed "control userpasswords2" which brought up a window with all the accounts (blank of course because there are none - duh) and an option to reset passwords. Of course I couldn't choose this but there was a check box where upon I had an option to just log directly into windows without going via any of the user accounts.
Great !!! I have it at last, a method to get in past the user accounts (which aren't there anyway). At least that's what I thought...

I rebooted my PC and it thought about it, it really did think about it. For a second I thought I was getting in and then I get a message on the screen... "The system could not log you on, make sure your user name and domain are correct then type your password again, letters and your password must be typed using the correct case."

Argh !!!!!
I don't have a password, I've never had a password, no one has set a password by mistake! Doesn't the stupid machine understand that !

Back to the drawing board. I refuse to believe that a full reformat is necessary. There must be a workaround for this somehow...

Maelstrom May 13 2006 11:10 AM EDT

Try my earlier suggestion: take out the hard drive, set the pin to "slave", hook it up to another computer, and either fix the problem from there, or backup your data and reformat.

AdminQBnovice [Cult of the Valaraukar] May 13 2006 11:12 AM EDT

There would be if the OS you were running didn't suck.

Fire clenses all b, just let the magnet do it's work!

bartjan May 13 2006 11:16 AM EDT

'set the pin to "slave"'

Why doesn't anyone use 'Cable Select'? No need for jumper changes when moving drives.

SNK3R May 13 2006 11:21 AM EDT

Did you try adding a user while in the "control userpasswords2" menu?

Try this, if you haven't:

When you get to the command prompt, enter "control userpasswords2" to get to your menu. Click the "Users must enter a user name and password to use this computer" checkbox. This will enable you (or should) to add a user in your account list. Follow through the instructions with the user as "Administrator" first to see if that does anything. I've never added a user this way, so I'm not sure what the computer asks you to input other than the username and password.

AdminG Beee May 13 2006 11:30 AM EDT

No SNK, I didn't try that at the command prompt, however it's one of the options when setting XP back up again after using hte recovery. I tried to set two new accounts at that point the first time round and it didn't work.

AdminG Beee May 13 2006 3:13 PM EDT

Sorted!

A full re-install of Windows XP (not a hard drive re-format) eventually fixed the problem. Lots of advice from windows whilst installing that I shouldn't be doing it over the top of another version, but Roughneck who had had the same problem in the past told me it was the only thing to fix it. Correct - it was.

Of course, now all my applications are gone (not the files, just the apps), but it's a small price to pay for getting what is in essence a second computer back up and running again.
As soon as I get the internet connection going and some other applications up and running I'll get wifey off my back too - bonus !

AdminShade May 13 2006 3:55 PM EDT

yay!

AdminNightStrike May 13 2006 11:09 PM EDT

Too bad I didn't see this post sooner. I have a bootdisk that you could use that would have fixed your problem.... it used to happen to some xp-sp1 installs that I maintained a year ago.
This thread is closed to new posts. However, you are welcome to reference it from a new thread; link this with the html <a href="/bboard/q-and-a-fetch-msg.tcl?msg_id=001mnS">Windows XP problem.</a>