Finally cbstuff has the chat client! (in General)

AdminShade February 28 2007 1:15 PM EST

sorry for the delay, had some things to do which came first :)

bartjan February 28 2007 1:25 PM EST

bartjan@zarniwoop:~/ChatClient$ java -cp . ChatClient username password carnage 7007
Exception in thread "main" java.lang.UnsupportedClassVersionError: ChatClient (Unsupported major.minor version 49.0)
        at java.lang.ClassLoader.defineClass0(Native Method)
        at java.lang.ClassLoader.defineClass(
        at Method)
        at java.lang.ClassLoader.loadClass(
        at sun.misc.Launcher$AppClassLoader.loadClass(
        at java.lang.ClassLoader.loadClass(
        at java.lang.ClassLoader.loadClassInternal(
And no, that is not because the username/password used in above example...

AdminShade February 28 2007 1:56 PM EST

Don't look at me, look at the people who created it :)

AdminJonathan February 28 2007 2:36 PM EST

I'm pretty sure that means "this applet can only connect to where it was downloaded from."

(There's a standalone NFC client available but I don't think I updated it to support the features I added for CB at all.)

AdminNightStrike February 28 2007 4:35 PM EST

You're using the wrong version of the client. I'll send you the latest.

AdminNightStrike February 28 2007 4:36 PM EST

Newest version sent to your gmail account. Note that we're not out of beta yet on this little project.

bartjan February 28 2007 4:41 PM EST

Shade's gmail account?

AdminNightStrike February 28 2007 4:42 PM EST


muon [The Winds Of Fate] March 1 2007 5:53 AM EST

Eh my bad. That must have been the version I compiled on the other machine.

I have a few different boxes with a few different versions of java installed; on one of them I have the J2EE installed, on the others I have the J2SDK. When I compiled with J2EE it wouldn't work on normal JRE machines (for obvious reasons which slipped my mind when I did it).

My apologies for this.

muon [The Winds Of Fate] March 1 2007 6:13 AM EST

Also, it isn't in applet form currently (I am kinda-sorta planning on converting back to an applet version if need be, but only after finishing some more functionality).

Current Features:
Alphabetical Name List
Font Selection (have to write a text iterator so this will work as it should, but it's usable as it is)
Colours (planning on writing a colour selection dialogue one of these days)
Autoscrolling Text (but if you want to read back, you have to toggle it off with /autoscroll. I had a piece of code which should have worked, but it didn't... not sure where the bug was. Again, will be looking into this in the future).

Still To Do:
Font stuff - as above
Colours - as above
Auto scroll - as above
Labels - need to label each text pane and the userlist
Applet - convert the class back to an applet for kicks and giggles; applets cannot use sockets to connect to any other host than localhost due to security considerations, and some of the parameter stuff will have to be recoded.


If any kind soul is half decent at Java, and doesn't mind the inevitable bout of nausea when reading my ugly, hacked up code, then please download the client and have a bash at doing the changes.

KEEP A LOG of what you did, and please comment your code.


AdminShade March 1 2007 1:54 PM EST

CBstuff updated with the version NightStrike sent me. :)

bartjan March 1 2007 2:24 PM EST

The version I've just downloaded is the same version as NightStrike already mailed me, and which contains the same files (minus some small changes to the readme) as the previous version found on

Miandrital March 1 2007 2:29 PM EST

Would you mind fixing the window resizing too? I'm running this on debian and this is what my window looks like when I try to resize it:

bartjan March 3 2007 5:56 PM EST

Any idea where to find the new supposedly working version?
With Sun's Java 1.4.2 it does not run at all (see error above) and with 4.1it does somewhat run, but resizing doesn't work, amongst other things.

AdminNightStrike March 3 2007 6:43 PM EST

1.4.2 is very old... use 1.5.0

bartjan March 3 2007 7:16 PM EST

1.5.x breaks the chat applet in a much more horrible way than 1.4.x...

bartjan March 3 2007 7:37 PM EST

Just tried it with IBM J9 VM (build 2.3, J2RE 1.5.0 IBM J9 2.3 Linux x86-32 j9vmxi3223-20060504 (JIT enabled) and this one seems to work perfectly (apart from not being an applet). Resizing, scrolling and all.
This thread is closed to new posts. However, you are welcome to reference it from a new thread; link this with the html <a href="/bboard/q-and-a-fetch-msg.tcl?msg_id=0022cU">Finally cbstuff has the chat client!</a>