Some sidebar changes under the hood (in Changelog)


AdminJonathan February 17 2008 1:45 AM EST

Verifex has updated the sidebar with modern, more maintainable javascript. If you see any problems,

1) right click in the sidebar, choose "this frame -> refresh" or the equivalent in your browser
2) if you still have problems, close the CB tab in your browser and re-join CB
3) if you still have problems, describe how to reproduce it here, along with what browser you are using

AdminNightStrike February 17 2008 2:04 AM EST

Switching characters in IE6 throws a javascript exception.

QBRanger February 17 2008 2:04 AM EST

I cannot change characters. When I try I get:

Unable to connect to CB.
errorThrown: Undefined
textStatus: error

QBRanger February 17 2008 2:05 AM EST

I use the latest FF version.

SimplyNic February 17 2008 2:05 AM EST

Same problem as ranger

SimplyNic February 17 2008 2:15 AM EST

Same as Ranger... Again...

AdminJonathan February 17 2008 2:31 AM EST

fixed

Relic February 17 2008 2:38 AM EST

Enter no longer works for fighting. I am using the latest version of FX.

Gunny Pew Pew [Red Permanent Assurance] February 17 2008 2:41 AM EST

Works for me, Glory.

AdminJonathan February 17 2008 2:44 AM EST

remember enter only works if the opponents combobox has focus. it's always* been that way.

*always = as far back as I remember

Relic February 17 2008 2:44 AM EST

Hmm, I had to disable fex's script to get it to work again. Might just be a javascript collision.

bartjan February 17 2008 2:45 AM EST

enter is also broken for me, after I just refreshed the sidebar, so it may be related to the fix for switching characters.

AdminJonathan February 17 2008 2:52 AM EST

> I had to disable fex's script to get it to work again

ah.

yes, I should have added "disable script" as step 2.5.

Yukk February 17 2008 2:58 AM EST

I have to concur. Enter doesn't work for Firefox 2.0.0.12 with no Verifex script.

Yukk February 17 2008 3:02 AM EST

I now have to disagree with myself. After several more reloads it works again.
Odd because I had reloaded before too.

dversouri February 17 2008 3:03 AM EST

same issue, firefox 2.0.0.6

dversouri February 17 2008 3:03 AM EST

disregard that. worked after refresh.

Bull3t F4c3 February 17 2008 3:16 AM EST

i use both fire fox and safari (both the latest versions) becasue sometimes on im my desktop and sometimes im on my macbook. i get the same problems as ranger but that was a few hours ago. i will see if its still like that later. on safari the lines around "quick links" run through businesses and recent battles as if they are being crossed out. also when i switch from favorites to standard the favorites fight list does not change.

bartjan February 17 2008 3:42 AM EST

It now also works for me, after another refresh.

AdminQBVerifex [Serenity In Chaos] February 17 2008 4:06 AM EST

Please disable my script if you have any problems with the sidebar. I have a new version of the script almost ready, just have to put the bookmarks and training set stuff back in.

Underage Drinking February 17 2008 8:04 AM EST

enter button disabled jsut now during fight breaks, using ff 2.0.0.12, on a side note, anytime i try to use Lorenzo to fight, i always get the page that says to wait or ill get a 10 penalty. makes him un-usable

The Pope [Serenity In Chaos] February 17 2008 8:19 AM EST

can't change characters with firefox...

AdminG Beee February 17 2008 8:31 AM EST

Works for me Pope. Have you followed the steps as mentioned above by Jon?

QBRanger February 17 2008 9:04 AM EST

Does not work for me.

Same errors even after disabling greasemonkey.

QBRanger February 17 2008 9:07 AM EST

Instead of disabling grease monkey, I uninstalled the old script and now things work.

Admindudemus [jabberwocky] February 17 2008 9:38 AM EST

c enter works for me until i do something like delete an opponent in my favs list. then it will not work and i will have to refresh to get it to working once again. i am on firefox, not using grease monkey or fex's script.

QBJohnnywas February 17 2008 9:39 AM EST

Same as Dude.

Lumpy Koala February 17 2008 9:42 AM EST

same as dude. But I use IE7.0

Koshka February 17 2008 10:35 AM EST

Enter to fight stops working after using Higher and Lower in standard opponents - works after frame reload, but still. Ffx 2.0.0.12, no other scripts running.

AdminJonathan February 17 2008 10:37 AM EST

fixed broken-enter-after-list-modification (verifex, see change 2760)

AdminJonathan February 17 2008 10:38 AM EST

and yes, you'll need to force a sidebar refresh again to get the fix.

Brakke Bres [Ow man] February 17 2008 10:48 AM EST

disabled greasemonkey, refreshed the bar. Still nothing here.

Admindudemus [jabberwocky] February 17 2008 10:52 AM EST

c enter is really broken for me now, the c works to advance the list but enter will not work to fight at all.

Admin{CB1}Slayer333 February 17 2008 10:55 AM EST

Latest firefox, several refreshes/closing and reopening browser/disabled and uninstalled script and I'm still not able to use Enter

AdminJonathan February 17 2008 10:55 AM EST

checklist:

1) uninstall verifex's script
2) refresh sidebar as I gave instructions to above
3) restart browser
4) click fight
5) now arrow keys, c, and enter should work

if not then you did something wrong in steps 1-5.

if this does work but you have problems elsewhere please report the specific problem like dudemus did.

AdminQBnovice [Cult of the Valaraukar] February 17 2008 11:00 AM EST

I went through 1-5 in order and even checked to see that firefox.exe wasn't running in the proc list. Still no fighting using enter.

AdminQBnovice [Cult of the Valaraukar] February 17 2008 11:01 AM EST

(I've never had GM on this machine, so I can't uninstall the script)

AdminQBnovice [Cult of the Valaraukar] February 17 2008 11:02 AM EST

a second refresh AFTER the browser restart made it functional

AdminJonathan February 17 2008 11:03 AM EST

sorry, bug with my fix. fixed better. (this is why it worked after your second refresh, novice.)

AdminQBnovice [Cult of the Valaraukar] February 17 2008 11:08 AM EST

fails again (until refresh) if you go to Standard list and back to Favorites

AdminJonathan February 17 2008 1:31 PM EST

also fixed

Yukk February 17 2008 1:35 PM EST

Not for me. Hit standard, then favorites = enter.
Hard reload, enter works. Standard, fav = no enter.
Quit browser, restart, enter works. Standard, Fav = no Enter again.

Still running no scripts and no grease-monkey installed.

theskier [Star Trek] February 18 2008 6:33 AM EST

A problem that I noticed last night, and tried again this morning, was when I changed characters the equipment screen did not change with it. I am running IE 7, no scripts. I have tried refreshing the left bar, and also closing and restarting the browser.

miteke [Superheros] February 18 2008 8:06 AM EST

I had the same problem, but it's gone now.

Brakke Bres [Ow man] February 18 2008 9:01 AM EST

viewing characters on the equip page:

Switching characters don't automatically switch the main window to that character you're switching to.

{cb1}Linguala February 18 2008 11:14 AM EST

Got the same problem as henk bres...I found refreshing or clicking the equip link on the left bar does force the switch though.
If the setup of your coding is how I think it is, this should only require some moving around of a line or 2 to fix.

Little Anthony February 18 2008 3:01 PM EST

sorry if i did not get it. but where is the script.?

Admindudemus [jabberwocky] February 18 2008 3:15 PM EST

anthony i am not sure i understand your question, but if you have not downloaded and installed the grease monkey add on for firefox in order to use verifex's script, then you can skip that step in the list that jon made. it is not an integral part of cb but an add-on.

Brakke Bres [Ow man] February 20 2008 5:21 AM EST

enter seems to work with the script now :) but only when you click fight first :)
This thread is closed to new posts. However, you are welcome to reference it from a new thread; link this with the html <a href="/bboard/q-and-a-fetch-msg.tcl?msg_id=002Lwu">Some sidebar changes under the hood</a>