Yeeee-argh! (in Off-topic)


Goodfish February 27 2009 10:15 PM EST

I'm pretty vehement right now- mostly at myself.

I own an external HD which has most of my older games (StarCraft, old-school WarCraft, Dwarf Fortress, and all my ripped PSX .iso's [legal, I own the CDs]), my music (30 GB and growing), and my music videos (probably two dozen of them, mostly stuff ripped from YouTube).

And it crashes. And is unrecoverable. My computer recognizes it exists but hangs whenever I try to open it.

Not only am I out a huge part of my life (music and games), but a significant time and money investment. Most of the games I no longer know where the CDs are (one of the problems of sharing with Tetra, haha), and ditto with most of the music- that, or I found it on some random site giving a free download.

I am also not really excited about the prospect of paying a hundred and fifty bucks for some recovery company to get the stuff back.

End rant.

Anybody know of a reliable way to, even potentially, get this stuff back? I tried PC Inspector, no dice.

Tal [G6] February 27 2009 10:19 PM EST

only thing i can think of is a hard power reset, have it search for a file then unplug from wall, restart computer and plug back in

AdminQBnovice [Cult of the Valaraukar] February 27 2009 10:32 PM EST

Tal: what?

first step is to stop trying to use it, you might only have one shot at getting the data

What makes you say it unrecoverable?
Does it sound different?

Goodfish February 27 2009 10:33 PM EST

Well okay. Here's what happens:

I plug it in, both to the wall and my computer. My computer recognizes it as a "Mass USB Storage Device". I open up "My Computer" to check the external disk, and then "My Computer" stops responding. I wait about forty minutes and about half the time my computer finally recognizes the external drive. I then attempt to open it (just like any other disk drive), and my computer hangs. The instant I shut off the external, my computer works fine again.

Daz February 28 2009 12:15 AM EST

There are a large number of things you can try.

You can use a ghost program to create an image of the drive which you can attempt to recover stuff from using a tool such as some Cyberforensic suites or whatever. You can get some of them free, I just can't remember any names.

You can try freeundelete and recuva. I've used freeundelete to recover stuff before, and it works, its just got a crummy interface. Recuva is made by the people who make several other tools I use, so I expect it would be okay.

Good luck!

I lost a 500 Gig drive recently, so I understand your pain. On the plus side, the games should all be pretty easy to get back~

Khardin February 28 2009 5:37 AM EST

Have you tried connecting the drive to another computer?
Perhaps the drivers are corrupt or were broken during an update or something like that..

iBananco [Blue Army] February 28 2009 9:18 AM EST

Ziploc -> Freeze for a day -> Try again and work quickly. Only get whatever you can't replace.

Flamey February 28 2009 10:19 AM EST

if its a 3.5" that's in a case, why dont you pull the cover off and plug it in and give that a go, the cables could be stuffed.

Varcas February 28 2009 10:55 AM EST

Open a command prompt and try to view the contents of the drive via command line rather than windows GUI.

Start->Run->cmd

whatever drive letter its normally assigned when plugged in, at the prompt type driveletter and colon. C: for example, and press enter

Then type dir and press enter. If that works, google for basic command line commands and see if you can copy your files that way.

[P]Mitt February 28 2009 11:07 AM EST

JS is right. If you can't do anything, put it in a ziploc and freeze it for a day and plug it in. Try to pull off what you can.

Ariac February 28 2009 11:18 AM EST

If 7's idea works, then you should have the hard drive back permanently as long as you keep it below a certain portion. There could also be a specific file on there that's keeping it from working. Try taking the last thing off of it that you added...assuming his method works.

AdminShade February 28 2009 12:16 PM EST

I had something similar happening also.

some disk checking tool seemed to work on another machine.

Goodfish February 28 2009 6:26 PM EST

Thanks for the suggestions, all. I'll try plugging it into my roommate's computer and running the command prompt. If that all fails, I'll freeze it...
This thread is closed to new posts. However, you are welcome to reference it from a new thread; link this with the html <a href="/bboard/q-and-a-fetch-msg.tcl?msg_id=002fxQ">Yeeee-argh!</a>