Purchase BA (in General)


Wraithlin January 18 2010 7:51 PM EST

am I the only one not able to purchase BA? The link isn't working for me atm, tried 2 different computers.

AdminTitan [The Sky Forge] January 18 2010 7:51 PM EST

works for me.

Demigod January 18 2010 7:51 PM EST

Working for me.

AdminTitan [The Sky Forge] January 18 2010 7:56 PM EST

That did just happen to me though, right after I said no. Try refreshing, it fixed it for me.

DoS [Battle Royale] January 18 2010 8:39 PM EST

After clicking cancel, I am unable to click (get more), edit, specify, fight, inspect, delete, or standard.

Like titan said it is fixed by refreshing the page.

Wraithlin January 18 2010 8:53 PM EST

Problem was scripting wasn't allowed on either of the computers I was trying to use, when i temporarily allowed it, the link would break and after refreshing the page, would again only give me the choice to temporarily allow scripts.

If you have this never ending loop problem, you have to go into internet options and enable scripting to fix it.
This thread is closed to new posts. However, you are welcome to reference it from a new thread; link this with the html <a href="/bboard/q-and-a-fetch-msg.tcl?msg_id=002yeF">Purchase BA</a>