Chatmail Change (in Changelog)

AdminQBGentlemanLoser [{END}] December 15 2005 3:10 AM EST

:) Can't believe I'm the first to mention this.

CM's displayed on the home page now show "Sent" in the message and "Replied" at the end, when you reply to one.


QBRanger December 15 2005 3:14 AM EST

I cannot now reply to CM's from my homepage.

maulaxe December 15 2005 3:41 AM EST

very nice!

or course, the "constructive criticism" begins:
could chatmail not be sent if preceded by "SENT:"? that seems like the logical path to follow, given the current change...

QBRanger December 15 2005 3:58 AM EST

Works for me now.

I had to refresh the page.

AdminQBGentlemanLoser [{END}] December 15 2005 4:24 AM EST

One comment. Keep clicking reply after the first and it keeps sending with an additional SENT: attached to the start of the message...


Stephen December 15 2005 4:25 AM EST

Let's have GL reset for spamming!

AdminQBGentlemanLoser [{END}] December 15 2005 4:28 AM EST

Hey! :(

And I didn't need to spam to test it, just click an additional one or two times...

AdminShade December 15 2005 4:56 AM EST

I dont see it working? Or perhaps nobody cares to send me CMs anymore :p

still don't see any changes...

{CB1ate}aupStar December 15 2005 8:07 AM EST

You can see when the message was sent and when it was delivered..I don't much like the change as people will think your rude if you don't reply to their message instantly...=/ I usually take my time with such things...donno, it's probably just me...=)

AdminJonathan December 15 2005 8:54 AM EST

you've always been able to see that

Maelstrom December 15 2005 9:00 AM EST

I get a popup: "error submitting data" when I click on the "reply" button. Pushing 'enter' (as before) still sends the chatmail.

Using Firefox...

WeaponX December 15 2005 9:05 AM EST

same thing mael

AdminJonathan December 15 2005 9:16 AM EST

you probably just need to refresh, like Ranger

Maelstrom December 15 2005 9:23 AM EST

it was supposed to be active when I logged in, but I've refreshed anyway, so someone send me a CM ... not too many people, though ;)

Maelstrom December 15 2005 9:28 AM EST

Thanks Ranger. Still got the error, though.

AdminJonathan December 15 2005 9:35 AM EST

no, you need to do a complete refresh

control-R etc

You've found G_Beee's burried Admin treasure.
Make a post in General pointing to this thread and you can claim the $1,000,000 CB reward.

[Update: This treasure has been found - sorry, you're too late!]

AdminJonathan December 15 2005 9:36 AM EST

... and you can send yourself a chatmail to test, you know

Tezmac December 15 2005 9:37 AM EST

Awesome change Jon, thank you! No more replying to a chatmail, going back, replying to another, going back.... :O)

Maelstrom December 15 2005 9:39 AM EST

Nope, full refresh didn't work, nor did restarting browser. The computer's been on for a few days, so I'll try a reboot...

And it didn't occur to me to send myself a CM. Kind of depressing to have to do that, isn't it? ;)

AdminJonathan December 15 2005 9:46 AM EST

well, good luck

it's definitely on your end; works in FF and IE

Maelstrom December 15 2005 9:57 AM EST

Nope, still not working after a reboot. It works in IE, though. What's wrong with my Firefox? :(

(And I just noticed that the item drop-downs on the home page are the "normal" size in IE, since NW was added. They're still taller in FF.)

Maelstrom December 15 2005 10:03 AM EST

Naturally, the problem was that Firefox wasn't up to date. Just got version 1.5, and the the chatmail stuff works. ;)

AdminShade December 15 2005 10:08 AM EST

Ahh no wonder: i have Firefox 1.0.7 here also...

... :)

AdminShade December 15 2005 10:32 AM EST

part 2

Firefox 1.5

Still go to the page:

Carnage Blender => Mail sent

Chat Mail has been queued for later delivery.
Back to WildEagle's page Chat Mail Home

AdminShade December 15 2005 1:33 PM EST

Neither does it work in IE for me...

note: I won't go whining over this because I find the way it used to work good enough and if it keeps working this way for me it's also ok.

Just strange...

AdminJonathan December 15 2005 3:34 PM EST

I downloaded portablefirefox 1.07. Works fine for me.

Try this:

type "javascript:" in the location bar. hit enter. hit the Clear button on the window that pops up.

send yourself a chatmail. reply to it with the new button.

see if any errors appear in the javascript window.

AdminShade December 15 2005 3:40 PM EST

I do get some errors: most of them have to do with the cb.css and some with the sidebar.tcl

but i dont even see a new button at all, sorry...

AdminShade December 15 2005 4:07 PM EST

got the thing why it isn't working

hitting enter after typing the CM will make it go to the other page

clicking send after typing will make it note (sent)

AdminJonathan December 15 2005 4:14 PM EST

well, yes

I thought people were complaining about a bug :P

AdminJonathan December 15 2005 5:05 PM EST

okay, enter will now perform the async submit.

Verifex thinks this might fix the error messages some people were getting. I'll cross my fingers since I never did manage to reproduce that.

AdminShade December 15 2005 5:17 PM EST

works perfectly here :) thanks jon

Vaynard [Fees Dirt Cheap] December 15 2005 5:25 PM EST

What should I try to do to fix it? On chatmails that appear on top of the page, typing a message then hitting enter, or hitting Reply, gives a pop up error submitting page. Refresh and restart haven't helped.

Maelstrom December 15 2005 5:27 PM EST

Get the latest version of your browser.

Vaynard [Fees Dirt Cheap] December 15 2005 6:02 PM EST

Good deal, thanks for the advice. It's weird, Firefox wasn't finding any updates, yet there was a new version online. Ah well. Everything works now. I guess CM only works with the newest version of FF now? Should there be a note of this somewhere for new users to find?

bartjan December 15 2005 6:05 PM EST

Chatmail continues to work as usual, when you let it deliver in chat (it's called chatmail for a reason...).

AdminJonathan December 15 2005 6:05 PM EST

CM still works with FF 1.0.

QBOddBird December 16 2005 10:51 AM EST

I have FF 1.07, but it is still giving me the error submitting there another update I missed or something? =\

bartjan December 16 2005 10:59 AM EST

I can reproduce the error, with FF 1.07 (Linux). Both hitting enter and hitting send will give the same popup. Hitting enter in adition produces the following in the javascript console:

Error: [Exception... "'Permission denied to get property XULElement.selectedIndex' when
calling method: [nsIAutoCompletePopup::selectedIndex]"  nsresult: "0x8057001e
(NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: :: anonymous :: line 84"  data: no]

Source File:  Line: 84

AdminJonathan December 16 2005 11:55 AM EST

are you sure your browser is loading the most recent version of MochiKit.js? It should be version 1.1.

bartjan December 16 2005 12:32 PM EST

I can't check right now what version of MochiKit.js that browser had loaded, but I do know is that that PC was powered on just today (and it wasn't used at all since Wednesday morning), and I did refresh the entire page before doing my tests.

What's odd is that on my computer at home it works as advertised in FF 1.0.7 (same Debian package, but at home I'm running unstable, at work testing).

AdminJonathan December 16 2005 4:54 PM EST

to rule it out whacky solar winds causing you to get broken code, please email me the html for a page on which you can reproduce the problem.

bartjan December 16 2005 5:04 PM EST

First encounter with that PC will be next Wednesday...

AdminJonathan December 16 2005 5:13 PM EST

works for me :)

(although I extend the offer to anyone who can reliably reproduce the problem, not just bartjan)

AdminJonathan December 22 2005 12:10 PM EST

from the lack of emails I've received I'm going to conclude that this is working for everyone now.
This thread is closed to new posts. However, you are welcome to reference it from a new thread; link this with the html <a href="/bboard/q-and-a-fetch-msg.tcl?msg_id=001daY">Chatmail Change</a>