Custom x bug (ask +10, get +11, pay +11) (in General)


iBananco [Blue Army] February 19 2009 12:14 AM EST

Goes to the number specified + 1.

QBRanger February 19 2009 12:54 AM EST

Yes, it is a bug and seems to give you that extra +1 for free.

I tested on my MOD on The Funkes and it seems I received an extra +3.

Did 3 tries, hence the +3.

QBRanger February 19 2009 12:56 AM EST

I take some of it back.

The extra +1 is not free but indeed charged. But as JS states, the number you put in is advanced by 1.

DoS [Demon Forging] February 19 2009 12:58 AM EST

Yeah, the extra 1 is charged.

Jolly Ja5on [Warlords of Smithy] February 19 2009 12:58 AM EST

I tried it and what ranger said in his second post is true. I ordered an improvement of one but got an improvement of two and was charged for both.

AdminShade February 19 2009 1:24 AM EST

I've modified the thread title a bit to be more descriptive :)

Soul Eater February 19 2009 2:17 AM EST

The fix for this is to just order one less than you wanted. That way it will end up being the number you wanted it to be.

AdminShade February 19 2009 3:01 AM EST

That's a manual fix but should be fixed in the programming rather than us being smart... :)

Wascally Wabbit [The Kat Forgery] February 19 2009 4:06 AM EST

I'm tempted sorry but does that imply that you don't think we are smart Shade? .. q=-P

Daz February 19 2009 5:18 AM EST

Never assume that people are smart.

AdminShade February 19 2009 5:42 AM EST

What I mean is that it isn't convenient to have to subtract 1 from the amount of multipliers you want to be upgrading.

Alternatively you could divide them up but that's just adding another problem :p

chaosal February 19 2009 7:18 AM EST

hm, what happens if you don't have the money for the extra +1? depending on where it's implemented...

QBJohnnywas February 19 2009 7:29 AM EST

I tried earlier to see what would happen if you don't have the money for the extra. It wouldn't carry out the upgrade full stop.


chaosal February 19 2009 8:46 AM EST

aw. as expected, but somewhat disappointing nonetheless.

QBRanger February 19 2009 9:05 AM EST

Still the benefit of the new "custom" is well worth the negative in that we have to remember to order 1 less then we want.

It is a bug I can live with.

Admindudemus [jabberwocky] February 19 2009 9:53 AM EST

added to the known issues wiki thread:

http://www.carnageblender.com/wiki/Known+Issues

Adios Muchachos February 19 2009 10:36 AM EST

the reason it happens is very simple whats a base weapon start with? 1

that out of the way 1 + lets say you want 2000 it will be 2001 without you paying for the first 1

Admindudemus [jabberwocky] February 19 2009 10:56 AM EST

there are two ways for it to work, you either put in the amount of upgrades you want or you put in the level you want it upgraded to. i think, if i understand correctly, that it should be working the second way. so if you want your item upgraded to 2000, then that is what you put in and it should stop at 2000 and charge you for upping it 1999 times.

it seems to be going to 2001 and charging you for 2000 times. even though you are in effect telling it that you want it to stop at 2000. i haven't played with it so am not sure but this is what i have gathered from the discussions.

AdminJonathan February 19 2009 2:09 PM EST

should be an easy fix.

AdminNightStrike February 19 2009 2:10 PM EST

It's fixed, but you probably won't see it unless you do a shift-refresh.

AdminNightStrike February 19 2009 3:58 PM EST

Tal - the bug was that internally, damage modifiers (weapon x) are zero-indexed. The display, on the other hand, is one-indexed. It's a simple matter of subtracting one from the displayed number.
This thread is closed to new posts. However, you are welcome to reference it from a new thread; link this with the html <a href="/bboard/q-and-a-fetch-msg.tcl?msg_id=002fZ6">Custom x bug (ask +10, get +11, pay +11)</a>